Unable to Run a Flow in Salesforce

Symptom

  • After triggering flows in Salesforce flows that seem stuck

  • After triggering flows in Salesforce, the Flow Execution Panel does not open

Cause

This issue is the result of a user having insufficient permissions in Salesforce.

Solution

Smart Flows versions earlier than 4.18 must configure Salesforce users to have the following minimum permissions set by their administrator in the user roles settings:

  • View Setup and Configuration

  • Assign Permission Sets

  • Manage User

For more details on permissions, please refer to the PermissionSetAssignment.

Smart Flows versions 4.18 and later must have the following:

  • Salesforce users with a role of Experlogix Smart Flows User role or higher

  • The profile for the Salesforce user must be set to "Minumum Access - Salesforce"