Error- invalid step in path during schemaobject retrieval
Users have reported these errors that occur during the execution of Generate document in the Flow Execution Panel.
Symptom |
Cause |
---|---|
When creating a document from a certain template, an error displays with the message "Error- Problem during compilation com.invenso.xbi.common.exceptions.SchemaException: Invalid step in path during schemaobject retrieval: /Contact in expression /Incident/CustomerId/Contact/Suffix" |
This error is due to an invalid mapping in the template, which is most likely due to a missing field in the data set. This usually happens when CRM fields (that are mapped in the template) are removed or renamed. |

Remove the field
1. | Open the data set in the Smart Flows Project Console. |
2. | Select the Edit button. |
This reloads all the fields.
3. | Select the Save button. |
4. | In Microsoft Word, open the template. |
5. | Select the Refresh button. |
This reloads the data set.
6. | Remove all the mappings that map the missing field. |

Rename the field
If you rename the field, this will also remove the error, follow the steps below for guidance on renaming a field.
1. | Open the data set in the Smart Flows Project Console. |
2. | Select the Edit button. |
The system reloads all the fields.
3. | Rename the field to its new name. |
4. | Select the Save button. |
5. | In Microsoft Word, open the template. |
6. | Select the Refresh button. |
The system reloads the data set.
7. | Update the mappings of that particular field. |
You must update the field mapping because the previous mapping still points to the previous name.